Archived Games made with Maniacs Patch don't show up in EasyRPG

Basically, I am having an issue with EasyRPG not showing games made with Maniacs Patch that are archived. They show fine when not archived though, however if there is some solution to this that would be great? I did try to search if this has been brought up before but can’t seem to find anything on this issue.

I have tried to use both 211010 and 210414 Versions of the Patch, neither worked after archiving the export folder
I am using EasyRPG Windows 64bit version
Works fine when not archived
Without the Patch, Games show up fine archived

The Game only consists of the following:
Title Screen is skipped
Map 1:
1 Event:
@> Show/Hide Player: Transparent ON
@> Change Menu Access: Disable
@> Change Save Access: Disable
@> Open Video Options
@> Text: Currently no intro, moving to next scene…
@> Wait: 1.0 seconds
@> Transfer Player: [0002:Title Screen] (009,006), Retain
Map 2:
1 Event:
@> Wait: 1.0 seconds
@> Show Picture: 1, ‘UI Box Standard’, (160,180), 100%, 0%, M5

I understand I could just not archive my game, or just not use the patch, but it’d be nice if I could archive my game while using the working features of the patch.

Hi. Can you upload an “archived” game that uses Maniac Patch and fails to display?

Otherwise I cannot say what the problem is because the Player does not care whether the game inside an archive uses Maniac patch or not.

1 Like


So now I am thinking it has to do with my settings within 7zip? I don’t remember changing anything but maybe I did(I feel so dumb if this is indeed the case which I am starting to think might be or at least, some other simple thing I am forgetting or overlooking).

More Details:
7zip Archives don’t show

.zip Archives do show but have the following error:
Error loading RPG_RT.ldb
Easy RPG Player will close now.
Press[Enter] key to exit…
Also, this is in the Log:
[2024-03-22 18:30:05] Debug: EasyRPG Player 0.8 (2023-04-29) started
[2024-03-22 18:30:05] Debug: =======================================
[2024-03-22 18:30:05] Debug: CLI:
[2024-03-22 18:30:05] Debug: Clock: StdSteady steady=true period=ns (1 / 1000000000)
[2024-03-22 18:30:05] Debug: Seeded the RNG with 1711132202.
[2024-03-22 18:30:05] Debug: SDL2: RendererInfo hw=true sw=false vsync=true
[2024-03-22 18:30:05] Debug: SDL2: Detected format (0) SDL_PIXELFORMAT_ARGB8888 : rank=(2)
[2024-03-22 18:30:05] Debug: SDL2: Selected Pixel Format SDL_PIXELFORMAT_ARGB8888
[2024-03-22 18:30:05] Debug: Controller 0 (Xbox 360 Controller) added
[2024-03-22 18:30:05] Debug: Detected ZIP encoding: UTF-8
[2024-03-22 18:30:05] Warning: ZipFS: RPG_RT.ldb has unsupported compression format. Only Deflate is supported
[2024-03-22 18:30:05] Debug: Encoding not detected
[2024-03-22 18:30:05] Debug: Game Directory:
[2024-03-22 18:30:05] Debug: 1: [Zip] Zodiac(MP210414).zip (UTF-8)
[2024-03-22 18:30:05] Debug: 2: [Native]
[2024-03-22 18:30:05] Debug: SaveDirectory:
[2024-03-22 18:30:05] Debug: 1: [Native] → Zodiac(MP210414)
[2024-03-22 18:30:05] Warning: ZipFS: RPG_RT.ldb has unsupported compression format. Only Deflate is supported
[2024-03-22 18:30:05] Error: Error loading RPG_RT.ldb

So I am not sure how to resolve the unsupported compression, sorry I am not that knowledgeable but it’s probably something simple isn’t it lol.

I have also definitely had archives working before, and unless I’m mistaken, I swear 7zip files showed up before.

Anyway, in case it’s needed, I have uploaded the entire folder with both 7zip and .zip archives with the log. I also included a picture in the archive that I uploaded with my settings in 7zip for both .zip archiving and .7z archiving. (918.2 KB)

Well the logfile states what the problem is “Warning: ZipFS: RPG_RT.ldb has unsupported compression format. Only Deflate is supported”.

The compression must be set to “Deflate”.

In 7zip I think the default is LZMA, in the type dropdown you must pick Deflate (not Deflate64)

Ok I got it working on .zip with delate, I do not have delate options in for .7z though, this is odd as I don’t remember ever using deflate until just right now to fix this issue, my usually methods are LZMA for .zip and LZMA2 for .7z and I never change them, yet I’ve definitely had no issue with EasyRPG Player reading my archives in the past, so it’s odd than now I have to archive with deflate? And despite not having a deflate option for .7z, I definitely remember starting Games archived as .7z, so thats a bit confusing.

We have no support for .7z archives. No idea why this ever worked for you. “Strong” compressions like 7z is not suitable for games because decompression is too slow.

We filter by extension and only files that end on “.zip” are displayed.

For .zip we only ever supported Deflate. Did you really always create them with 7zip? The built-in Windows zip feature uses deflate.

Yes I always create archives with 7zip because I am able to use it on OS other than Windows including my Pi400(I try and use software that is available on the majority of my devices).

Well maybe I misremembered, but as far as I am aware it worked fine before. Well anyway, thank you for your help!, as long as I can archive it I am happy lol.

Wait, so before I definitely remember one of the things I did was put a password on the archive(I was doing some experimenting with what I could do with archived games) and this definitely worked before. Now with doing the same thing with a deflate .zip archive, it comes up with the same error as before.

This not working, when before it did, makes me certain that, for whatever reason, I was able to get nondeflated method working before, or at very least it was working with a password set(the reason this stuck in my mind is because to me, it made no sense that it could read an archive with a password set).

I am completely clueless how this worked before and not now, but wanted to put this here so maybe someone might solve or very least, have an explanation for this.

I wrote the ZIP code for the Player and I can assure you that really only Uncompressed and Deflate work. :thinking:

Encrypted archives will fail to launch (but the filenames are not encrypted)

Yeah I recognise you from the github packed games support page that came up with my initial search(thx for the all the responses btw!).

I realise it shouldn’t have worked, I was surprised myself but it definitely did work for some reason, the thing is I kept deleting everything since I was only testing it out, and I have since moved things around, not like that should do anything(although you never know with tech related stuff lol).

Ok ok, I was thinking that usually, I write things down, and in my planning doc I wrote this down:

Archive: 7zip(Passworded AES-256 Encryption) with 128MB LZMA2 Dictionary Size(130MB MEM)

Now I can assure you I would not have written in this if it didn’t as I make sure everything works before I write it in the document. It’s just annoying that I didn’t take pictures or took a video lol

But I am certain now that it worked before, as I wouldn’t have written it in my planning otherwise.

Edit: I realise this is very weak in turns of proving I got it to work, but I did, I just don’t understand why or how I got it to work lol, as far as I am aware, I just downloaded the player, moved it to my project folder, and started archiving my exported game folder and it just sort of, worked? But now it doesn’t :person_shrugging: