Browser version problems with .flow


#1

I’m having trouble with getting the website version to work, I’m using IIS on windows to host it, I can connect to the website just fine but when loading the game it says “Exception thrown, see JavaScript console” but there is no javascript console… I’m so confused.


#2

found out what the console was… i never thought i could be this dumb… but anyways its saying “index.html.mem not found” and also i figured out that I did not change all the sound files to ogg and i did not replace rpg_rt with the easyrpg player exe but i cant do that second one because the download links are all broken


#3

wait the continuous version links are not broken


#4

image
this is the console…


#5

im gonna try using itch.io to host instead of my actual pc, maybe things will work better there


#6

hi, I’ve restarted a service it was down minutes ago, maybe you got broken links due to this.
Is the .mem file accessible from the URL bar in your local test? This file must be actually uploaded to you server to work, it is in the same archive.

About .ogg, consider trying .opus instead with opusenc 1.3rc2 from opus-tools 0.2, it is more efficient than ogg vorbis. mp3 and wav are supported too if you want to try the game as is first.

You may also consider converting png pictures into xyz with our tools by running png2xyz and then xyzcrush for the smallest picture file size.

The wiki is up again with the up-to-date guide at https://wiki.easyrpg.org/development/player/web


#7

how do i upload specific files then? it just asks for a folder, which i have and everything i need (i think) is in it
image


#8

OH I got it to recognize it! added mem application/octet-stream in the mime file registry thing… now i just need to get the easy rpg player to recognize the game, but i think I know why thats not working


#9

the index.json file seems to have “?” instead of the japanese characters, how do i make it not do that? would applocale or something work? or is that because im trying to view it with an english encoded program?


#11

its saying it cant find rpg_rt.ldb and rpg_rt.lmt even though i added them into the mime filter and they definitely are there. this is so confusing


#12

index.json is the generated cache file and this file needs to be created per-game.

So, if your “games” folder contains inside a “default” folder which contains inside RPG_RT.* files, place the index.json there. Some games (.flow maybe) contains inside a “data” folder, all content inside “data” must be placed in the game folder (e.g. “default”). If you use another folder name, you need to use in the url the index.html?game=foldername so default may be useful to keep the url cleaner if you are not planning to add more game folders. Adding a . before the folder game won’t work properly (.flow is not a good name).

About Japanese characters, could you upload the generated index.json to take a look? flow game is known to have mojibake issues. Try adding this to the index.html url when you try: index.html?encoding=932 or if you have the game parameter, something like this: index.html?game=flow&encoding=932


#13

sorry I didn’t see this reply until now, but i found out the request filter was blocking the rpg_rt.lmt file, so i fixed that and the game runs. but, every file with japanese characters isnt recognized even with the index.html?encoding=932 tag, so it looks like the index.json file isn’t encoded correctly, plus setting the encoding in notepad++ keeps all of it as question marks, so yeah
index.zip (4.6 KB)
heres the index.json file, it wont let me upload a json file so its zipped


#14

i tried running gencache through applocale and it did not fix the problem but did change the “???” into normal unicode gibberish so that seems like an improvement?


#15

To me it seems the extracted files are the problem, as the index.json is valid utf8. Have you tried a different extraction program (i.e. https://theunarchiver.com/command-line)?
Also, can you actually see the japanese file names or are they even question marks or gibberish on your file system?

However, gencache might be even broken on windows, I have no way to test this currently.
If nothing else works, we could even prepare a .flow package with all things set and provide it.


#16

gencache has no unicode support on Windows.

The code will fail when the files are not in the local codepage because using the widestring API makes everything messy. This will break the use case when somebody wants to create a cache of a japanese yume nikki on an european Windows… (https://github.com/EasyRPG/Tools/pull/22)

Therefore using applocale with japanese encoding to create the index.json should work. you put it than in games/default and everything should work.

Also check the network tab in your browser console. You can see there when it requested rpg_rt.ldb and how the URL it attempted to download from is.


#20

thing is, it works fine with the normal easyrpg player, the default player, and i can see the text on my file system, so idk
a fully prepared one would be great but idk if its super necessary

did that, and it didnt work…
and thats how i found out it was blocked in the first place

tested it on the wii version and it works there too but that might not actually be relevant

tried with yume 2kki, can run it fine with the ?game tag but! same problem…


#21

still having trouble, anyone have any new possible solutions…?


#22

should i just give up at this point?


#23

Could you provide us with a link to the website where you hosted the web player? Then I could debug it by myself and tell you what is wrong. (when the link is not public you may send me a private message)