Error loading RPG_RT.ldb

I’m trying to use easyrpg player to play “the 7th stand user”, but after the putting the 7th stand user folder inside the easyRPG games folder and selecting the 7th stand user item, I get the error in the title. I used to get a different error but reinstalling the app fixed that one. Anyone know what’s going on with this one?

Edit: There are perhaps 2 more things I should note. After the error, I’m brought back to the easyrpg select a game screen except there’s no games and tells me the games folder does not exist, but gives me an option to open the game folder which opens my recent stuff for some reason. The other thing is that error only appears to happen the first few times after reinstalling. After that it just crashes and sends me to the previously mentioned games screen until I reinstall again.

Edit 2: Something else I found, I’m not sure if it applies to all games or just 7th stand user, but putting the zip file in the games causes EasyRPG to insta crash into the no games screen.

Edit 3:Further testing reveals all the issues above apply to Yume Nikki as well and most likely all other games as well.

Edit 4: So I’ve been doing so reading regarding installation instructions and it seems like most people use an sd card. I do not have one so i’ve been using internal storage, could this be issue?

I installed 7th Stand User on my device and it works fine.

The problem for this change are no security requirements enforced by Google so we cannot go back to the old version.

Which location on the internal storage did you choose?

OK, so I’m still not sure what the exactly the issue was, but I managed to solve it by installing using the apk instead of from the app store. I think the it’s because easyRPG was having trouble with accessing the folder assigned to it.
Also for the record I had tried to use both a folder in the highest level directly in internal storage and one in my downloads folder.
Word of warning, like I mentioned before, it does indeed seem to work, but sometimes it stops working and I have to reinstall it from the apk to get it working again.