Monigote Fantasy: Several issues


#1

Hello there!

I’ve been testing EasyRPG on my RM2k/3 project (Monigote Fantasy, which, by the way, I’m translating into English) and I’ve found a couple of issues there. I’m attaching an example that covers the first three of them.

  1. In RPG Maker, three events can freely move over the same tile as long as their priorities are different. I mean, a character can walk over some event whose priority is “under the character”, and, let’s say, a bird on the “above character” layer can fly over said character. However, two characters can’t naturally occupy the same tile, in the same way as two “birds” couldn’t do so. This is implemented correctly in EasyRPG when it comes to walking, but it’s not when JUMPING.

  2. The “return to title screen” instruction doesn’t work properly in the latest version.
    It just takes the character to the map with the player starting position but doesn’t restart the values of variables, switches, screen color tone, weather effects, etc.

  3. This is a bit tricky to explain, so maybe it’s better if you open the project yourselves and take a look. It’s about the autorun event that runs at the beginning of the example.
    With RPG Maker you can skip the scene by pressing Enter or just wait 3 seconds for the picture to disappear, while with EasyRPG you always need to push Enter to carry on. I think it must be some kind of problem with the key input processing method.
    But this one is particularly weird, because if you simply add a message instruction into the event, it’ll stop working that way in RPG Maker. (??)
    (The message in the log is “Event exceeded execution limit”)

  4. The spacing in the descriptions of the items or spells is half the size of a space in RPG Maker but not in EasyRPG, causing some of them not to be displayed completely.
    Picture here.

  5. The character won’t move when you load a game that you saved from the menu screen. Only the Shift key works. However, if you saved the game by using some kind of save point event (which are rare in the game), it works well in Windows, but not in the Android version.
    I keeps happening even if I switch off all of the common events running in parallel. If you need further details, let me know. Has this happened to anyone else? I’d be pretty interested.

I hope you find them useful, you’re doing an incredible job with the project.


#2

Welcome and thanks for this detailed report :slight_smile:

Based on some of your issues I believe that you used 0.5.4 and not the continious build (the development version) which is available at the bottom of the download page: https://easyrpg.org/player/downloads/

It is possible that we already fixed Bug 2 (this one sounds very familiar), Bug 3 and Bug 5. Could you test these again (and create new savegames instead of reusing the old ones)?

Also the equipability in the screenshot of Bug 4 looks incorrect, this should be also fixed in the continious build.

Bug 1 and 4 are new for sure, we will track them in our bugtracker :slight_smile:


#3

Thank you so much!
I just tested them and, as you said, Bug 2 and 5 had been fixed in the development version.
The savestate one now works like a charm. Thanks! :smiley:
As for Bug 4, the usability arrows bug is solved, too. Not spacing problem, though.
Tested a little more and found out damage numbers in battle look a bit messed up sometimes. Picture here.

By the way, speaking of battles, there are some features which are yet to be implemented, right? Especially in 2k3.
You’ve probably got a list so I don’t think it’ll help if I write here some of the ones I’ve noticed so far. If you want anyway, I could write them in the corresponding thread.

And if there’s something I can do to help the project, please let me know. :slight_smile:


#4

Recently we made lots of changes for the 2k battle system therefore it is possible we broke something in 2k3 battle. There are many smaller and bigger quirks but would be nice if you could list them (check first against the development build).

The big ones we already know:

  • Everything in the CBA/Battle Weapon related is not implemented
  • In some cases the background is wrong / not animated
  • The pointer when choosing an actor/target is off by some pixels
  • ATB-system behaves different

Please add anything else you noticed, even minor things.


#5

Thanks for replying.

Having checked them in the development build, I’ve got these:
· Multiple attack weapons just attack once.
(Is that what you meant by “Battle Weapon related bugs”?)
· Skills don’t work if their attack element list CONTAINS one element beyond those by default (#18 onwards). Picture here.
· Multi-target weapons deal damage to just one foe when “Auto” is selected. By the way, in 2k/3 the “Fight/Auto/Escape” screen shouldn’t be there.

This one doesn’t have to do with battle, but with music. Here’s an example:
Once you get on a vehicule, the reference to the music that was playing is stored, and if you move to another map for whatever the reason while still on the vehicule (for example, going to the deck of your ship), the music changes to the new map’s specific BGM (while RPG Maker player keeps playing the “vehicule music” despite the map change).
If you get off the vehicule in the new map, then EasyRPG will start playing the stored one (music #1), while RPG Maker changes from the vehicule music to the new map’s music.
(Sorry if it sounds repetitive and redundant. :stuck_out_tongue:)


#6

The music bug with vehicles is another corner case nobody thought of before. Fortunately it should be easy to solve.
Edit: Fixed by https://github.com/EasyRPG/Player/pull/1620


#7

Death Handler won’t work if “Call Common Event”/“Transfer player after death” is selected instead of “Game Over” in the database, and will take the player to the Game Over screen in any case. Here’s an example.

In the particular case of my game, it doesn’t even take you to the Game Over screen, but rather, the game will let you wander freely around the map you were at, even though you’re dead. I don’t know why this happens, but I guess if the first problem is solved, so will this one.


#8

We had similar problems in “Huntress of the Hollow” before, seems we missed a case. @Ghabry knows better.


#9

The spacing and the vehicle issue are fixed by now in the dev build.

For multi-attack weapons: We implemented this only for 2k by now but it will also land in 2k3 soon


#10

Nice!
What programming language are you using? Is there any way I can help you?


#11

Any type of help is welcome. Reporting bugs is already a huge help :smiley:

You can find the sourcecode at github: https://github.com/easyrpg/player . We use C++.

We also have a chat btw:
#easyrpg in freenode IRC or via
Matrix: https://riot.im/app/#/room/#easyrpg:matrix.org (They are bridged, pick any)
There is also a Discord which is also bridged but I don’t want to advertise non-open platforms, so please google this manually :wink: