New user - Anyon175


#1

Greetings,

My name is Anyon175 and I’m a brazilian Maker.

I played RPGMaker games since the RPGMaker 95 version and many of the RPGMaker games I played were not brazilian. Some were english (Legion Saga, Baldy’s Big Day, A Blurred Line, The Way), some were in german (Vampires Dawn, Velsarbor), others were italian (Theory of the Order, Fifth Era) and even japanese (With-Walker/Romancing Walker, Seraphic Blue).

I’m also a programmer. Most of the time I use C# and Java, but I also know a little bit of C, Javascript and Python too.

I don’t know if I can be much of a help, but I can be a Tester too. So far I found almost no bugs when I played RM2K games using EasyRPG, like even the japanese/russian games with different font styles are working good so far.

The only games I had some problem either didn’t have their RTP or they used a different map format like ‘Laxius Power 3’ or ‘O Segredo do Espirito’. Games with DestinyScript also do not work (which is actually understandable).

But besides that, I played the following games without problem so far:

  • Fifth Era - Fragments of the Holy Stone (Italian)
  • Velsarbor (German/French Translation)
  • Librium (Russian)
  • WITH-WALKER (Original Japanese version of Romancing Walker)
  • Romancing Walker
  • Rygar e os Soldados do Rei (Brazilian)
  • Heart of Evil
  • Las Aventurietas del Robercleiton TURBO (Brazilian)

Hope I can help with the EasyRPG project in some way.


#2

Welcome and thanks for the testing :slight_smile:

What do you mean with different map format? Is an error message shown?

Can you list some games that use DestinyScript? I’m only aware of two games using this which means the priority to support this is very low.


#3

Hey Ghabry, thanks!

So yea, I actually made a mistake. Laxius Power 3 is working just fine but 2 brazilian games have a different map file format or file extension. One of them is named ‘O Segredo do Espirito’ or ‘The Spirit’s Secret’, the other one is named as ‘The Drake Legend’.

I don`t know if the games were made in a modified version of RPGMaker 2000 or if they were modified by some program afterwards.

Regardless, both games work on Windows but they won’t show up in EasyRPG.

3

Also I don’t have a list of games in DestinyScript, I just found out after trying to make my own game with it and then trying it on my phone afterwards. I just pointed it out so that you guys would know about it.

So yeah, if you want I can also upload both games if you guys wish to test it out. I will try other games and see if I can find more bugs, but so far most of them work fine.


#4

This looks like a really lame obfuscation, to prevent editing these games in the editor (and as a side effect break playing in EasyRPG).

Your only way to get them working is to fix the extensions.

The database must be called RPG_RT.ldb and the map tree RPG_RT.lmt.
For the maps (lmu) you will need a tool because there are so many.

Because you have Windows you could use the command line (cmd):

rename *.ext *.lmu

Or use some GUI for batch renaming.


#5

Hey Ghabry,

So yea, I tried that once some time ago on both games and it didn’t work. I believe that not only the map files were renamed but also other files like the *.LDB, *.LMT.

2Print

In The Spirit`s Secret after I renamed the map files the game crashes when you open it, saying that it cannot open the file ‘OSdE Título’. I thought it was a .LBD file and tried renaming it but it didn’t work. I opened it in Notepad++ but it wasn’t in pure text, it seemed more like a program or a DLL. There is also a .BAK file, which I presume is a backup for the old RPG_RT.exe.

In the case of Drake Legends even the main RPG_RT.exe seems like it uses some different DLL files (I didn’t check if it was a DestinyDLL because both games are likely too old for that, they were made in the year 2000 or so).

5Print
3Print

Perhaps in the case of The Spirit’s Secret there wasn’t a patch involved and it just renamed everything, but in the ‘The Drake Legend’ case seems to me like it used a patch of some kind. If both games are too heavily modified that’s too bad, but I would totally understand if the EasyRPG couldn’t run them.

EDIT: So yea, I also tested two games, Blades of Heaven and Kindred Saga Battle System (Which is a different game from Kindred Saga). Blades of Heaven seems okay so far but Kindred Saga BS on the other hand had an error from the EasyRPG log. Something about an invalid skill not being learned. Possibly a skill deleted from the skill tree or something like that.


#6

Once you renamed files (i.e. oselmu or extlmu), there is no way to run the modified RPG_RT, as it has been patched. So you either need an unmodified engine or use our Player (we also provide builds for your Windows desktop system).


#7

Hey carstene1ns,

Thanks, I tried renaming the LMT and LDB files as well then I used windows version of the player and it worked just fine.

There was a log in The Drake Legend because it showed a little movie intro and I know that’s not implemented yet. But still very cool.

I also have some screens from what I have played so far. I didn`t see any problems.

So yea, thanks again for the help guys. :slight_smile:


#8

Thanks, your feedback is much appreciated!