Problem with an RPG2K game


I found this app on Google Play Store and decided to try using it for a game named VHゲーム01.
It’s made from RPG2K.
However, I haven’t been able to get it to the title screen, much less get to play.
It keeps on returning “Image not found: Title”.
I have tried playing it on all three encoding options [Japan, EU and the other one].
Not one mode makes it work.

I have the appropriate RTP, and I know it’s not an issue with the game because the game works [not perfectly, but playable] on the only RPG2K player in the Play Store. I won’t name it per se, but it has Choco on its name.

Any help on this?

My device

Make: Lenovo
Model: A369i
Chipset: Mediatek MT6572
CPU: Dual core, 1.3 GHz
GPU: Mali 400
RAM: 512 MB
Screen resolution: 480 x 800
Operating System: Android Jellybean 4.2.2
Rooted: Yes
Other notes: Firmware is not modified, I use the one it came with [from the factory].

Well that can be due several reasons particularly because the name is on jap, if possible provide a url to download the game so we test it.

Additionally to that review the paths on the sd card and that the files are located were they should be. The RTP paths are correctly configured ?


Hi, thanks for replying so soon.

The download link is!1hxnVSAS!RVpbJHyxY … yiTvxqgSSo
Due to the developer’s request, the archive is password-protected. The password is “nanako” (quotation marks excluded). It is the name of one of the game’s protagonists.
As for the RTP, the files have correctly been placed in sdcard0\easyrpg\rtp\2000


Under Windows this fails for me directly when parsing the LDB Database. The database is probably “corrupted” (fields with incorrect length information), will need some debugging to find the field. RPG_RT is more tolerant about this then we are…

Is it that bad? What’s your hypothesis on this? I’m sorry I don’t know jack about these stuff.

Hi, looks like this game may have been patched. There are multiple subfolders and original RPG Maker 2000/2003 does not support this.

Is this game working fine with an original, untouched, RPG Maker 2000’s RPG_RT.exe for you?

I just use the RPG_RT.exe provided when I’m on Windows. I haven’t tried replacing any files that were provided by the dev.

I implemented a rudimentary solution for the few games that use sub-subfolders in my experimental branch (for devs: … cbb0b622ee ).

Unfortunately, the english RPGTranslator patch corrupts the files enough to break easyrpg. The japanese unpatched version works, but the player gets stuck during the flashback section (around 5 minutes in the game).