RetroArch/EasyRPG uses 1 thread in full when the game window lose focus

Whenever I had EasyRPG player running, and then I click on to another program, there will be a thread with 100% utilization by RetroArch/EasyRPG.
Screen recording of this happening
This doesn’t seem like an issue caused by the game… I tested two games so far.

Today I tried downloading new version from CI builds and the problem is fixed for me… IF you open easyrpg from command line. (with --window switch)

Use double click on easyrpg-player executable will create black screen, and your mouse cursor will get stuck in black screen.

So that behaviour I encountered must be patched a few months ago… retroarch didn’t provide newer version.

Thanks for the report. It is possibe that this is a RetroArch issue. Does this also happen in other cores?

The EasyRPG core wasn’t updated in a while. We hope that this happens again when the buildbot migration is done (the libretro team currently works on using a new one that is easier to maintain).

The bug can’t be reproduced in our normal Player because we use our own way to detect is the focus was lost. RetroArch gives us no control over the window focus.
The broken fullscreen is a known issue with the CI build. For working fullscreen you must build from source or use a OBS package: (GNU/Linux -> OBS)

I didn’t try any other core because I just want to play RPG maker games in Linux.

Today I tried Ubuntu PPA version ( from OBS and the audio is messed up. (Can’t really tell what’s wrong but the audio is wrong, like, sounds very different from normal)

I guess I will stick with CI build from now.