Some problems with a very large and heavy scripted game (rpgmaker 2003)


#1

Hi,

First of all cool that easyrpg exists, really kudos for coming up with something like this! I have personally made a very large and heavy scripted game in rpgmaker 2003. I worked seven years on that game and I would love if it could be played on a mobile. a lot of things don’t work in easyrpg just by playing it for 1-2 minutes – and I suspect this is because it does not fully support all the functions in rpgmaker 2003

My game uses a completely custom battle system and it does damage by using variables – the problem is that – that damage does not show. It does subtract the damage from the monster but it does not show the numbers,

The second problem is – is that my game uses a custom level up system and – use the hero classes but somehow easyrpg does not look to this – making my game unplayable. If I remember correctly rpgmaker 2000 don’t have classes.
A third problem is that it loops certain parallel common events that involves one of the two clocks. As far as I remember rpgmaker 2000 doesn’t have that.

So my suspicions:

  • No support for the rpgmaker 2003 classes
  • No support for damage dealt in variables
  • No support for the second clock in rpgmaker 2003

If you want more details – I can specify it more for you. I will probably post a lot of more thing as time passes. I tested this on Android.


#2

Thanks for the post. Currently it’s not possible to distribute an invidual game on the PlayStore (so called “standalone mode”) but this is planned and we hope to get this working before end of the year :smiley:

Do we talk about Final Tears 3? Based on the screenshots on your website it looks like the gauge based RPG2k3 battle system. Or is that a complete replication of it?

Thats correct, we only have limited support for 2k3 classes currently.
Classes have many strange quirks thats why it’s difficult to get this all right.

This needs some context.
We will need a testcase for this, e.g. a minimal testgame that exhibits the behaviour or a savegame close to the bug in any game.

Hm, this should work. We will need a testcase for this, too.


#3

Regarding Final Tear 3, here’s a synopsis of what it’s doing during the intro, since, well, a bit of a malfunction occurs for me on: easyrpg-player-git 0.5.2.r57.g6325c23c-1

Current symptom is that a part of the intro infinitely loops.

Map 0719, “You will never disrupt < Intro pounder” is a night scene, just after the first bit of voice acting (which appears to be involuntary for the intro???). It’s driven by E2/Event talk, a parallel event.

After it’s done, it goes to Map0954, “MAP0954”, driven by E1/EV0001 (also a parallel event), which shows the “STEVIE V.D LAAR / PRESENTS” scene.
Map 0954 then goes back to Map 0719 for a sec, shows map, and then event execution stops there, because Map 0719’s event starts up again, and on EasyRPG Player it interrupts map 0954’s event.
I assume that on RPG_RT, it does not, and the map transition goes quickly enough that the intro lines don’t play, or alternatively, Map 0719 is the event that gets interrupted.

I’m not sure what, exactly, causes this - and as of this moment, a good argument has been made for adding tree expand/retract in my little personal project, just to save time helping describe what’s going on in a specific bug instance, so, I’ll be on that for now.


#4

Wow a lot of posts already. yes it is final tear 3 indeed. I recently found out that the intro loops as well and found more things in the mean time. It does not loop on windows btw.

As im not at home right now so i make it short. I will provide the things you ask for some later on. Im going to release 3.09 on friday - after that i can provide you the things you asked for. Thx for the quick response.


#5

Pretty sure a Player dev needs to make 3.08-B work anyway - as the saying goes, any deviation from RPG_RT is a bug
(EDIT: Hence the testcases - reduces the amount of event commands that have to be searched through to trigger the EasyRPG Player bug)


#6

Hi Ghabry,

I guess I have some time now to answer some of your questions.

It would be really awesome if we can share our games through the playstore standalone – I really hope you can pull that off. Though then of course there should be not any deviations from the rtp anymore.

I do have a small request with that and I don’t know if it is possible already. My game uses also some other buttons (4,5,6,7,8 ETC) than the standard ones. IT would be really cool if those buttons are already there so that the player doesn’t have to make it himself in the program. That I can make a standard button template beforehand for the game.

About the classes - I really hope you can fix that – because my game is unplayable if it does not. The heroes go to level 99 instantly after one fight some further in the game because of this.

About the damage in variables, I do this with changing the monsters HP in the monsters group. It will temporary put a condition on the hero where no action is allowed so that it won’t use the standard rpgmaker systems attack. It does subtract the damage in variables but it does not show the numbers it in battle. Another problem is that it does execute the standard rpgmaker attack while on Windows it doesn’t the condition somehow does not work correctly in easyrpg. The whole event is pretty complex to explain here. But I guess that something goes wrong in that part. I can provide a save game if you want. Give me your e-mail address and I send it you.

I get back on you some later on for the other questions you asked


#7

I also used a patch where you can up in higher stats - as you can see in the picture below I used for the stronger monsters higher stats that are possible in the normal database. Is that supported in easyrpg also?

databasereaper

Edit: the clock problem was a programming mistake of myself - I forgot to break a loop in that event. But I do have some more issues that I will post some later on :wink:


#8

Edit 2: Found another bug where a important boss battle freezes I can give u a save game for that -

Edit 3: also I used a custom border in some boss fights and it does not show and the boss is only halfway shown. I can send a save game for that one too. This happens with more bosses that have this border added by me.

See picture below
border

Edit 4: bosses and enemies also do not fight back trough the custom battle system they only use the dbs skills. I give some more details later on because I already posted a lot of stuff xD


#9

At least for the standalone game apps this should be possible, yes.

Wups, thats really bad :confused:

easyrpg AT easyrpg org
You can also use “report a bug” in the Android app while a go is running. It automatically attaches a logfile and savegames.
Or you simply attach it here in the forum, LSD is whitelisted.

Uhm I don’t think we artificially limit it, so maybe it works…

Send it ^^

Send it ^^

Tecnically you don’t have a custom battle system. CBS run on the map and are 100% custom. You are “Just” using a heavily scripted normal battle system… Which is even worse :wink:


#10

I sended you the e-mails trough the app.

About the limits. I cannot really test that as the system does not show the damage done in variabes. I hope you can solve of the problems with my bug reports.

You might want to download version 3.09 from my website. It solved some loop problems with the dark bottle - you might encounter in 3.08-B

Edit: Did you receive 5 e-mails? Because m e-mail program first showed it send 5 e-mails and now it says it sended 2 o_O


#11

Thanks, we received 5 mails.
We will tell you when we have any questions.


#12

Any updates? It is some time ago :stuck_out_tongue:


#13

Well, no rush. Bugfixes can take a long time because they become less but the difficulty to figure them out increases. Even reviewing the mails can take a while, in this case almost two months ^^. They will be fixed someday but we don’t give estimates.

By now I created 3 issues in the bugtracker:

A collection of all battle graphical issues (Wrong enemy position, wrong background, partly wrong system graphic)

Incorrect Charset in the shop.

The following reports of you have no bug report yet, but will come soon:

  • Class is changed to 99, I havn’t tried to confirm this bug yet.
  • Battle system scripting related problems. Need to figure out first what is all broken, the system is really complex.

#14

Thanks - if you need any explanation of the system or need access in my game let me know.