Struggling with EasyRPG on Vita

Hi there-I’ve recently found out about EasyRPG and was incredibly excited to play my favourites on the beautiful OLED screen that my vita has. Unfortunately, things have not been so well.

  1. I’ve been playing OFF and have run into a couple snags, where the c2-12828-1 error pops up. The first was in the combat tutorial at the beginning of the game, but I just skipped that and had no issues. The second is in the fight against Dedan at the end of Zone 1-which I can’t skip over obviously. I had zero issues with the game between these two spots, making this incredibly frustrating

  2. I do not know how to remap buttons in Yume Nikki, which has caused me to have to just turn off the game both times I’ve tried to play it. The first is that the default mapping did not have the escape key, so I couldn’t leave the mini-game on Madotsuki’s television. The second was that the 9 key isn’t mapped, so I can’t save. There doesn’t really seem to be a way to remap buttons to my eyes, but I could be not seeing it.

So far to fix it, I’ve turned the console on and off, and rebuilt my database. I wanted to check on here to see if these are known problems before I do anything crazy. I also have a hacked 3ds, so it easyrpg is known to be more stable on 3ds that is another options as well, especially if it means not needing to delete my save files somehow :smiley:

Let me know what u think-any suggestions are appreciated.

TF

Hello,

do you use the latest version of EasyRPG Player? Right now this is 0.6.2.1. (https://easyrpg.org/player/downloads/#release-other)

This is very unfortunate and shouldn’t happen. Does it always occur, even when using 0.6.2.1? If yes we can likely reproduce it and fix it.

The ESC for leaving NASU is a translation error. You must HOLD the ESC button (the one that opens the menu), not just PRESS.

Unfortunately remapping is currently unsupported. We are coming closer to a solution but right now it is just not possible. Sorry. Unfortunately one of the most popular games requires more buttons :(.
On the 3DS the numpad is available (is on the bottom screen) but you will need a New 3DS for the best experience and there are audio glitches. The old 3DS is a bit … slow.

Hey! thanks for the reply^^

I do have the most up to date system. I actually started using OFF with RetroArch’s RPGmaker with no issues, plus the music actually works now-which it never did in easyrpg. So I guess I made that work?? lol. Maybe that means the problem is with my download of easyrpg.

As far as the button remapping issue, my hacked 3ds is an XL, so hopefully I’ll be able to run it there with no issues-and I already have retroarch installed, so I will probably just put it on there.

One more issue-I can’t get 2kki to come up because of the japanese characters…is there a work around for that, or is that another issue on the ports that hasn’t been sorted yet?

I’m surprised that you have less issues with RetroArch because the easyrpg player core is a bit outdated.

Maybe the language is incorrectly detected? There is no way to overwrite this on 3DS or Vita. You must open the RPG_RT.ini of the game with a text editor and append:

[EasyRPG]
Encoding=932

Then the game will use Japanese as the language.