The Big Challenge? + Good News

Hello again people. Well, First things first, I noticed that the Android port was updated fixing an issue I reported here some weeks ago, so I decided to try last night’s build to see if that was also applied to the PC port. I’m glad to inform that indeed it works :slight_smile: (I feel useful :D)

Now Honoka is happy :stuck_out_tongue:

Btw, TGG issue was solved too. As it should be, Rawberry now can’t cross the walls:

Anyway, now the thing that matters: there’s a game I’ve played and loved playing it, but knowing it’s complexity I find it pretty hard for it to be fully runnable with EasyRPG.This game is none other than Standstill Girl (aka Teitai Shoujo):

I don’t know if you knew it or worked with it, but if you did, you know what I’m talking about. If you didn’t, well, here it is. I call it the big challenge because this game is pretty complex related to its code. It involves a lot of stuff I don’t know too, so I can’t give that big amount of details about its complexity. The point is, I’m pretty sure it won’t be easy to make it work properly with EasyRPG.
Up to now, in EasyRPG 0.3.2 after seeing the intro (one of the backgrounds doesn’t scroll properly and the clock ticking sound keeps playing until the end of the intro), you press Z to wake up the character and after she gets off the bed she can’t move at all:

However, by pressing X you can scroll through normally through the menu:

Now here’s something that was fixed in the nightbuild. In 0.3.2 the game gets screwed up when trying to access the submenu when you can change the character’s abilites, displaying this while the background flashes once:

In the nightbuild the submenu displays correctly without any problem at all:

Since you can’t move at all, you can’t proceed, so the game works up to here.
Well, that’s it for me. There are more details I want to add, but I don’t have enough time right now so I’ll add them later. Tell me if you want me to try something special with this game. See ya!

Hey, sorry that we forgot to mention in the other thread that the issues got resolved.
Good to see that also our nightlies help against some bugs :slight_smile:

The nightly versions of Android and the PC versions are completely on-sync, at least game play related bugs should be reproducable in all versions.

This hang is interesting because we know a different game that has exactly the same problems: The Sacred Tears TRUE. After the very long intro you are in your house and can’t move but open the custom menu.
In this game you can (no idea why) work around this bug by holding down SHIFT. Maybe it is worth a try to make it semi-playable?
The KeyInputProc event is surprisingly tricky to implement correctly…

Sacred Tears has very complex scripts, maybe the one from your reported game are simpler and easier to debug. We will check soon :slight_smile:

No problem with that. Besides, they were fixed with a night build, so the problems could appear again in future nightbuilds since it’s possible that this fixes may cause another problems (while testing TGG a window popped out reporting an error in a command line while I was trying to access the save menu. Hopefully it gave me the option to ignore it and continue normally).

What a coincidence :stuck_out_tongue:

[quote=“Ghabry”]In this game you can (no idea why) work around this bug by holding down SHIFT. Maybe it is worth a try to make it semi-playable?
The KeyInputProc event is surprisingly tricky to implement correctly…[/quote]
I see… I’ll give it a try.

If this game is more complex, then I’ve got to try it.

Warning! Spoiler alert:

One detail I wanted to mention previously and I couldn’t because I didn’t have enough time to put it is that I played through the game normally and saved right before a boss battle (Alice is right next to the event that triggers it) so I could see if it works. Battles are fully playable, Alice’s animations get a little messy while transitions between animations during a couple of frames but it soon returns to normal. Also, when the background flashes in battle animations (Spirit Thorn and Self-Holocaust for example) it doesn’t have transparency so the background flashes with full color (it’s hard to explain, but the point is that it’s different. Personally I find it nicer than in the original animations but it can be kinda epileptic):

Well, she’s Standstill Girl after all.
I’ve isolated this bug in a very simple test game and opened an issue in github for it ( Once it gets fixed, this game-breaking hang should also be resolved.

Standstill Girl does not standstill anymore in the latest release.

Awesome! I’ll check it out when released :slight_smile:

Is released since a few days :slight_smile:

Yup, I know, I tested it.
Great work! I really liked the game browser, way more practical.

Well, sadly Standstill Girl isn’t still playable. However, it has nothing to do with the movement issue. The problem now are normal battles. Somehow after a normal battle (even if you flee from it) Alice won’t appear in the place she was before entering the battle. She will appear in specific coordinates depending on the direction she was facing to before entering the battle. In 99% of the cases, the place where Alice is placed is out of the map’s bounds and you have to reset the game since you can’t do anything (the only exception to this is the training world, Alice still appears in an out of bounds zone but she can reach the event to return to the Time Core).
Since you can’t progress without normal battles, the game is still unplayable. This doesn’t happen when you lose the battle, after boss battles or after the tutorial battle.
Well, that would be it. As always, tell me if you need more details.
Merry Christmas!

It’s playable in v0.4.1. Also the running animation is shown properly. Awesome work, keep it up!

Great to know. Then we randomly fixed this bug :slight_smile: