Vampires Dawn - Reign of Blood


first of all thank you all very much for this great project :slight_smile: It is a blast to play again the good old games.

The game Vampires Dawn - Reign of Blood is working so far and saving works well, too. Unfortunately I can’t buy items. The money I spent is gone, but the items don’t go to the inventory after buying.

I thought with the new version it should be working, like it said here: and is fixed now.

I’m playing this on my Android smartphone (Samsung Galaxy S3 rooted).

It would be great if you can help me.

Have I the wrong version or is this bug still not fixed?

I’ve tried to download it from playstore and from

Thank you!

Welcome Darkztar,

The shop bug has been fixed in the 0.2.2 version but the Android version of 0.2.2 has not been released yet due to building issues. We don’t have an estimation about when this will be fixed. The current nightly build for android shows a black screen and needs to be debugged.

Thanks for the info.

The new version would be a great Christmas gift :smiley:

Tanks for your effort guys!

Hello :slight_smile:

Now the nightly build for android works again and I could start playing the game with working shops. At first thanks for this :slight_smile:

Now I’m noticed following bug:

In some point of the story I have to fight someone who is stronger than me and I can’t win against him (so intended). In this battle the opponent cast a spell which should end the fight and the story goes on with me passed out and then break out of a dungeon.

But after the opponent cast the spell the fight doesn’t end and I just loose against the stronger opponent in a normal fight and after a game over I have to start again and there is no way how I can work around this, so I’m stuck :frowning:

Is this a known bug?

I can give you a save game and show the sequence on youtube, how it should work. Would it help?

There wasn’t much time invested yet into the Battle event interpreter. There are probably lots of bugs hidden.

I havn’t played this game in a while but I assume you mean the battle against Abraxas where he casts Blutstarre I think which ends the scripted battle.
We can reproduce this using the “Battle Test” function so I don’t think that we need a savegame. Thx for reporting!

Yes, exactly this battle against Abraxas and his Blutstarre I mean :slight_smile:

Thanks for working on this

Should be resolved in the latest “continious build”. See download section.

Yeah thanks :slight_smile: That works now and I can play further.

Unfortunately now, where I have more fights, I found more bugs :slight_smile: I’ll post them here, maybe they are unknown yet:

I gave them a little priority list from important to not so important.

  1. Sometimes the game crashes in the fight after the character takes or gets damage. It freezes and the game crashes.

  2. In this game the Vampires have the ability to suck blood in the battle (from an opponent which has blood), but after using the ability no blood is gained, so this attack is useless.

  3. After a fight the hero should get souls according to the opponent: if it was a weak one, then a weak soul, a strong one then a strong soul, but the souls are never dropping unfortunately.

  4. If you fight more than one opponent in the fight and you use a spell which attack all opponents this spell takes the resource costs twice for one attack, respectively so often how much opponents you have.
    E.g. a spell costs 7 blood if you have 1 opponent and it takes 14 for one attack if you have 2, but it should take still 7. The same happens with items, which you can use for attacking all opponents. It uses 2 items for 2
    opponents for one attack, but it should use only 1.
    In the example above: If the hero has something between 7 and 14 blood left and you use the spell for 7 which attacks all opponents, so after the round you have 0 blood left.

    But the opponents take the damage of the spell/item only once, although the costs are doubled, besides the case in the next bug.

  5. Maybe according to the last bug: sometimes (not always) the hero uses the ability from the last round before he executes the new order (a new one or the same). So it happens that the hero attacks twice in a round.

  6. I’ve never saw a crit attack from my heroes and I fought quite a lot battles.

  7. If the map screen changes (e.g. new room) so all summoned creatures like Golem and skeleton are summoned again. Also if the here is transformed in a wolf or a bat, so the transformation is done again. It seems not
    to take any resources.

  8. Using a Savestone for saving the game doesn’t decrease the amount of the Savestones. So you can save without limits.

  9. Summon a servant (e.g. Golem) or use a transformation (e.g. into a wolf) doesn’t consume blood (resource).

If I find more, I’ll post them :slight_smile:

For now it is unfortunately not possible to play because the game crashes very often in a fight.

I created issues for your reports ni our bug tracker.

Could you provide us a savegame where you can already use transform (to wolf/bat) and summoning and have some save stones ^^.

And concerning the crash in 1.: Could you use the latest Windows 32bit continious build and try to crash it? This creates a dump file with a blue filename in the game directory (current_date.dmp). Could you upload this dmp file somewhere?










Ok, here I uploaded 2 dmps and a save file:

I used cheat engine to get some stuff like souls and soulstones and some items more like blood potions to be able to play, because no souls are dropping and “Blut saugen” doesn’t work either. So don’t be suprised xD

I created a github account, so I can report more bugs directly there if I’ll found something :slight_smile:

The download doesnt work because all free slots are in use -.-

Can you upload this on a more sane website like ?

Ok, here: