Wii port

Ok so this has a Wii port. I have the homebrew channel, the app shows up, but when I run it it says no games found and such things as that. Now, according to Wiibrew.org, each game needs its own boot.elf, in the same directory as the exe itself. I’ve tried some different things but they just aren’t working. I’m trying to run the game “OFF” by Mortis Ghost. Honestly what I need is a full guide to running this on the wii, but obviously this would be difficult for you lovely folks. If it helps, here are some screencaps of my SD.
This is the root of the SD, both the game’s files and the player’s files are inside of the “Easy RPG” folder.


This is in the Apps folder, same thing.

I’m really sad because the whole reason I homebrew’d my wii was for this :frowning:

Please help!

Welcome Mrcaimito,

Looks like you posted the same image twice.

Take a look to this post for a detailed file structure:

Oops sorry about that! It’s just inside the apps folder with the folder “Easy RPG Player” selected.

That post was somewhat helpful, but seemed to only be talking about the music files and RTP, I was unaware I even needed an RTP, I reckon that would be important. The error said database not found… does that sound like the RTP is the problem?

I simply extracted the entirety of the game’s files to the folder “Easy RPG Player”.
I have this folder in 2 locations: On the root of the SD as well as in the Apps folder, is one unnecessary?

Sorry to be such a bother, thank you so much for your time! :slight_smile:

In the linked post there is this link:


These files:
│ ├── meta.xml
│ ├── boot.dol
│ ├── icon.png
Must be in the same folder as RPG_RT.ldb. If the boot.dol is not in the same folder will show “database not found”.

Oops! Sorry I missed that :frowning:
Thanks so much! My apps/easyrpg folder is properly formatted: but not the data or etc. I know that there are instructions for the Etc. folder on the thread you posted, but with the RTP I downloaded it from the link on the site, but it’s just an exe… Should I run it and tell it to put all the files in /data? Also, can multiple games be loaded on the SD card at the same time for easy RPG? I saw a YouTube video of a fellow running Ib on this, but on the Homebrew channel there was “EasyRPG”, and “EasyRPG: Ib”. How can you do this?

Thank you!!

The RTP must be run on a PC and the .exe installer will unpack all filles into somewhere like c:\program files\rpg2000\rtp, then just copy the proper structure to your SD card.

The etc folder is for midi playback, you can use timidity freepats (e.g. from arch linux package) or this timidity pack from the sdl_mixer project:
libsdl.org/projects/SDL_mix … ity.tar.gz
you need to unpack it in your sdcard: /etc/timidity and this folder must contain timidity.cfg and such. Maybe this pack doesn’t contain a freepats.cfg file and folder but it should play midi anyways.

You can have different games, e.g. /data/somegame/ containing boot.dol, rpg_rt.* and map files and asset folders (title, gameover, etc.). To customize the game title just edit meta.xml and icon.png from a PC, this pair contains details for homebrew browser.

Ok… So the main game that’s in the same folder as the app itself is what will run when selecting EasyRPG player, but you can add additional games by placing them in data/game? Thanks again!

I think you can place multiple games in /data/, e.g.:



and so on

Ok thank you so much! I haven’t tested it yet, but I hope it works! I’ll get back once I test it. :slight_smile:

Ok the game runs, but there are problems. For one, the top of the screen is cut off, making the error messages unreadable. I’ve tried adjusting the aspect of my TV, but it doesn’t help. Second, i get error messages every time I enter a screen… since the top is cut off all I see is "Module format unsupported.’ Also, there is no music. In the first battle, the app crashes upon the first attack. The timidity seems to be formatted properly… Also, putting multiple games doesn’t work. I made \OFF in the data folder, placed the games files, meta.xml, boot.dol, and icon.png in the folder, and the homebrew channel still has only the EasyRPG player and the rest of my apps. Any suggestions?

Yes, this is the classic CRT screen issue. If you have a flat LCD screen then something is wrong with your LCD settings.

Which game? OFF? Please report any game crash you find. Please note EasyRPG Player is still in development and there are significant bugs yet. All bug reports are welcome.

Did you modify every meta.xml with some editor to make it different between them? If not, homebrew channel could not show them as different apps.

Ok I was able to put multiple games on the homebrew channel. OFF does crash when you attack in the tutorial battle, but Ib works flawlessly so far. To put multiple games I put the game’s folders in apps instead of data.
I’ll get back if there are any more problems, thanks for your help!!!

I can’t seem to figure out how to fix the LCD problem… Could you explain that?

It depends on your flat TV model and settings. Some models have adjustable zoom, fit to screen, preserving aspect ratio, etc. Check your TV manual for this.