Caterpillar issue still not quite resolved


Hi, another Wii user here. I know it’s been awhile since I’ve been here, but you know… stuff happened. :stuck_out_tongue: Anyway, tried out my game on the newest build, and after making a few changes, ran into a major game-breaking bug. As you know, the game runs with a caterpillar system. After going into the first dungeon, my characters clear that dungeon and then the screen goes completely black.!Ak_-0M2klpQtgU0f2nGsTrfxbWSz1

Some background information: This is a project I’ve been working off and on (mostly off) since about 2004 or 5. It’s an ‘old school’ sci-fi type game. It’s set in the year 2052. I laugh at it at times.

The game runs fine in RPG Maker itself. I have tested it there on numerous occasions.

This is the topic I’m referring to…RPG Player: Game freezes at the caterpillar point


Hello, is this an issue on other versions (Win/Lin/Android), too?

Can you provide a savegame close to the hang? If you can’t save in this game at that point you can use the debug save feature: Pass --test-play to the Player (for the Wii this is possible by editing the xml file and adding


When testplay mode is on you see a “Debug” option in the normal menu. If the menu should be disabled by the game you can call it through F11 at the computer or via “Hold SHIFT and press B 5 times”. Iirc SHIFT is “B” on the Wii and B is 1 or 2, can’t remember.

If it crashes on all platforms are you able to reduce the error to a minimal test case (reduce amount of events executed)?


Hi, sorry for not being able to get back to you. Been so busy this whole week… Anyway, just tried it on my phone and yes it happened on the Android version too. Screen went totally black after my two characters cleared the first easy dungeon. I’m beginning to wonder if this is an issue with coding. Thing is, I’m too far into this project to start over from scratch.


If it only happens in EasyRPG and not in RPG_RT it is obviously a bug in our code.

Just give us a savegame that is close to the problem.


Sorry it took so long Ghabry. Here’s the project file with a save.