Player 3DS Port


#1

@Mr.Faq2014 @Klauserus

I need a hardware test:

This DOL should have working music for WAV, MP3, MIDI and OGG:
https://easyrpg.org/downloads/tmp/easyrpg-wii-audio-test.tar.bz2

The 3DS sound test contains some test games:
https://easyrpg.org/downloads/tmp/easyrpg-3ds-audio-test.tar.bz2
The archive contains 3 testgames with suffix WAV, OGG and MIDI. This is the format of the Title and the Field music. For MP3 just use any game you want.

The Title music plays 50% faster then the Field music.

Looking forward to test results :slight_smile:


Wii Build: Test reports
#2

Cool, I’ll do it asap. Sadly I’m kinda busy with exams at college right now so I think I’ll get this done by next week. See you then

Btw, I can test the 3DS port too if you want for next. I have a normal 3DS that can launch both the cia version and the homebrew 3dsx version. I’ve been trying some nightlies and I look forward to it too


#3

Couldn’t contain the hype (actually I don’t have anymore exams up to the end of the month) and tried out the 3DS port this morning (I’ll try the wii one this afternoon). Sadly, it doesn’t start ;_; When I try loading it using Mario Kart 7 as target app it gets stuck with the last line being “step 5: svcCreateThread now hacked”.
Gotta mention that I also tried launching the app via the Homebrew Launcher loader that I can use to access homebrew while being in custom firmware mode. Unfortunately, despite loading the player gets stuck before the game selection screen. Tried to rush and press the L button to display framerate, and as I expected, it gets stuck because it doesn’t change after the EasyRPG logo fades out (got stuck at 42)


#4

Thanks for the test. The hang after the logo shouldn’t happen :frowning:
How long did you wait? But should not take longer then a view seconds.

About svcCreateThread: Are you on firmware 11.0? Guess I should just completely disabling this “khax” step. The only reason for it was to get access to the csnd audio service. But without access to it the player will just fallback to DSP audio which works fine, too.


#5

After the logo hung I waited a couple of minutes without any change at all. Dunno the reason for it to hang in there. About the svcCreateThread stop, no, when I launch it directly I’m still on 9.2 sysnand


#6

What will happen with the 3ds test build?


#7

Not entirely true, has partially the same issues as the audio test build. Won’t get past step5: “svcCreateThread now hacked” again if launched through HBL normally… but it will load normally if you load cfw first and then enter HBL through yellows8’s homebrew launcher loader (something to mention is that there’s no need to insert cartridge this way, it doesn’t ask for it to begin with). However, we still have the same issue as build 38 and the previous ones that supported mp3 files but didn’t have the step5 issue (18, 22, etc.). The player will still play an mp3 file only once. The next time the game instructs easyrpg to play an mp3 file, no matter if it is the same or a different one, the player will crash. The cia version will exit automatically to home menu, while the hbl version forces you to restart the console. Used build 43, build 44 is being built while writing this


#8

@Mr.Faq2014
Yeah, you were too fast… build 44 is the fixed one :frowning:


#9

Lol, sorry :s
Well, I’m testing it right now. And indeed, mp3 files play as intended :smiley:
Unfortunately… the step5 issue is still present… but still loads if launched cfw first (start cfw, open yellows8’s homebrew launcher loader, launch EasyRPG and it works). Plus, cia version works as intended too, and I expect the built-in cias to be that way too. So for now, I guess you can say that EasyRPG on 3DS is cfw-only…

Btw I did something I consider necessary: I made a (small) list of games you can and can’t use as target app when launching EasyRPG through HBL normally, despite being useless right now. I’m posting it in Rinnegatamante’s forum too:

This list may not be 100% accurate since except for Mario Kart 7 and the Lego Harry Potter game, the other games were tested using a Sky3DS I own instead of the retail cartridge which I don’t own. Also none of the default system apps work as target app (at least for me), if trying to set them, the top screen will get stuck with the keyboard that is expected to be shown in the bottom screen, but all meesed up and rotated 90º to the left, and the bottom screen will get stuck in red. Finally, I did the test on my 9.2.0 sysnand, I guess it may vary if you try in another console with a different firmware version (I think the list would become shorter, but who knows…). All right, let’s begin:

Working game target list:

-Mario Kart 7
-Super Smash Bros. for 3DS
-Mario and Luigi Dream Team
-Paper Mario Sticker Star (Seems to crash, but it actually loads…)
-Mario Party Island Tour (Same as PMSS)
-Yoshi’s New Island
-Tomodachi Life

Not working game target list:

-Lego Harry Potter Years 5-7 (gets stuck like default apps)
-Cubic Ninja w/ninjhax (stops with blue bottom screen, didn’t try without having the exploit installed despite it doesn’t work anymore…)
-The Legend of Zelda Ocarina of Time 3D (couple of junk bars appear randomly on the top screen and bottom screen remains red, but won’t go farther than that)
-Super Mario 3D Land (gets stuck like default apps)
-Mario Tennis Open (gets stuck like OoT3D)
-Ultimate NES Remix (gets stuck like default apps)
-Tetris Ultimate (gets stuck like OoT3D)
-Boulder Dash 3D XL (gets stuck like Cubic Ninja)
-Freakyforms Deluxe (gets stuck on red bottom screen displaying nothing on the top one. Yup, people using freaky hax won’t be able to use it… for some reason…)
-Senran Kagura 2 Deep Crimson (gets stuck like OoT3D)
-Out of region games (get stuck like FreakyForms)

Well, that’s it for now


#10

Thanks for testing. :slight_smile:

No idea why that step5 fails. Works for me on non-CFW.

The recommended launch title is the updated youtube channel (will be autoseleted when installed). And many people have it installed ^^


#11

Pokemon titles and Hyrule Warriors also work fine. It’s time I reinstalled Youtube. It’s annoying to have to scroll to Pokemon every time x.x

I have youtube on my other DS, the original mobo of my current one. But this one is A9LHaxxed, and I haven’t bothered getting YT x.x


#12

I think you will want to have a look at this,


while some BGMs plays, but other sounds are just noise.
Using build 46,and Nocturne freeze now


#13

I see, so Youtube works. Well, unfortunately I can’t download it since in that case I would have to create a new NNID to enter the eShop… long story, it may generate problems, it’s better for me to stick to mk7. Anyway, which model is the 3ds you tried EasyRPG in, Ghabry? maybe that’s the difference. I told a friend who also has an old3DS like me to try EasyRPG and he had the same problem


#14

I removed khax from the code, it should boot everywhere now :slight_smile:

The broken SE audio is not fixed yet, sorry, no time yet.


#15

@Mr.Faq2014

Here is a new test build which replaces the audio code with some work in progress stuff:
Can’t test it due to lack of 3DS.

https://easyrpg.org/downloads/tmp/3ds-new-audio-test.zip

Please test MIDI, too :open_mouth:


#16

Got it, I’ll post results in a while


#17

Sorry for double posting too soon, but it doesn’t get past the logo screen again… can’t test anything…


#18

hmm, in Citra it works :frowning: . Unfortunately can’t do any hardware test before december…

Does the easyrpg_log.txt contain anything of use?


#19

no log generated to begin with… I believe it’s pretty much the same issue we had a couple of months ago, mostly because I checked the fps counter as before, and you guessed it, it stays in 42 as before. Tried waiting several minutes, having several games to none in the folder, as well as with game data put directly into the folder, none of these attemps being successful. It will stick after logo no matter what, forcing you to restart the console


#20

@Mr.Faq2014
Does the normal continious build work for you or is it broken, too? If yes the problem is actually somewhere else in not in the new code. (I will provide you a CIA then instead)