Wii Build: Test reports


#21

Sorry, the 0.4.2 release got delayed :frowning:

But for some good news: Another developer added support for tempo change (50-200% play back speed) and software resampling.
This isn’t enabled for the Wii yet (needs some adjustments) but this means you will soon have proper sound effects and music playbacks of all formats on the Wii :blush:


#22

All right, now that’s cool :open_mouth:
Anyway, will there be a new date or period for 0.4.2 to be released in? Not gonna lie to you, I’ve been hyped all these weeks but didn’t question trying to avoid being a bother, you know


#23

If all goes well, we hope to get the release out until the summer breaks/vacation time for most of us start (that is likely before mid-august).
0.4.2 will be a bug fix release however, so no real new features planned. (Well, strictly speaking resolving the long standing audio resampler issues are made through supporting new libraries, i.e. new features)


#24

Ok then, I’ll be waiting :slight_smile: Keep it up!


#25

Concerning the Wii build the next one will fix OGG music (which no game uses :frowning: )

WAV music won’t be fixed, there must be a bug in our code, only generates noise :confused:

But shift will be remapped on the Wiimote and the classic controller has Yume Nikki friendly keymapping.

We do this in one go with the 3DS and Android port and wait for our 3DS testers currently. So the next release comes soon ™


#26

9 posts were split to a new topic: Player 3DS Port


#28

Tested Wii with Yume Nikki. WOAH the loading time is fast now!

I try to err on the side of giving too much info rather than not enough to be useful. Hopefully I didn’t go overboard :stuck_out_tongue:

Sound stuff:
Music was working anywhere I went. But there’s a static-like sound that happens when walking, except in the few areas where music doesn’t play (the house while awake, or the room with all the doors).

Seems like the combination of music + walking sounds is what causes the noise. Looks like most sounds and music are wav in Yume Nikki, so maybe the wav bug mentioned a few posts ago is the cause. I hope not though, cause it sounds like that can’t be fixed.

Other possible cause could be slowdown when moving. Standing still gets 60-61 fps. Moving while there’s no music playing goes down to 55 fps at the slowest, and no static sound from walking.

When there’s music playing and you move, fps drops to 47-51. And there’s both the static sound while walking and often music slowdown/distortion until you stop.

I also noticed a dramatic difference in the music in some areas between the test version and the previous version I was using (0.4.0) which was probably due to better accuracy. Particularly the music in the Dark World (found in the room with all the doors by going through the black door on the lower left) sounds completely different. I’ll try to remember to verify that the change is more accurate to the original pc version sometime when I have more free time.

Visual stuff:
For some reason the test version uses less screen space than older versions. There’s black bars on both sides of my crt tv (4:3 of course) that didn’t use to be there in older versions. The bars aren’t huge, but in previous versions (0.4.0 for example) areas that took up the full screen in game used to go all the way to the edge of the tv.

I think the aspect ratio might be a little off too (everything just a little too tall because it’s squished together a little on the sides) but it’s hard to tell for sure.

Background bug: I saw the scrolling background suddenly jumping around the screen sometimes when walking around. I can’t remember if that happens in Yume Nikki in the original game (not playing through EasyRPG) but I don’t think it did that. I’ll have to try to double check on that sometime if I get some free time. I don’t know if the pc version of Easy RPG does that either.

Anyway, the BG jumping around isn’t related to a specific spot in the game. It became clear as I tried to figure out what was causing it that it’s got something to do with where the background is scrolled to in relation to the position of the player/screen.

My best guess would be that when the scrolling background gets to a certain position (edge of background reaching either edge or center of screen?? very much just guessing there) Easy RPG gets confused about where the scrolling position should be and can get “tricked” if you move in the wrong direction at the wrong time.

That’s all very hard to describe. I took a short video with my camera to show it in action and maybe give an idea how to reproduce it on your end. If you figure out where in the background scrolling it tends to happen, it becomes pretty easy to make it happen on demand.

Gameplay stuff:
It’s probably something you already know but rain causes fps to drop by about 10 in some areas (not every area though).

Pretty nasty bug: I found there’s a room which drops to 0 fps, unless you have the streetlight item and have it set to red. Then it’s 60 fps like normal while standing still. But without the streetlight item, or with it set to green, there’s a constant 0 fps.

I took a picture of the room:

I think the problem might be that there’s a sound which keeps trying to play when to don’t have the streetlight set to red. That big creature’s mouth also seems to be trying to move when the light isn’t red, so maybe that in combination with the rain in the room is what causes it to slow down. I don’t know what it acts like normally because I had never found this room before :stuck_out_tongue:

Sigh. Now to try to describe how to get there. That’s always a challenge with Yume Nikki…

Go to sleep. Take the red door on the left in the multi-door room

You’ll be in the puddle world, which you can find a map of here:

You need to go in the red entrance in the middle of that map. It can be hard to find your way there but if you look at the map and use the lampposts as landmarks it shouldn’t be too bad.

After going through that red entrance you’ll be in a woods area and it’s raining. There’s a road at the bottom of this area. Go down to the road, and follow the road all the way to the right.

When the screen changes you’re still on the road but everything else is black. I think you have to continue going right for a while. It will endlessly loop in this room when going to the right. After it loops once (you can tell it looped when the faces in the background start to repeat) you need to head all the way to the left instead.

Now you’re in a forest area again, still on that road. Go as far to the left on the road as you can. You’ll see some traffic cones and a roadkill victim. Use the action button on the victim to get the streetlight item.

Now go to the menu and select the streetlight. Congratulations. Now you’re a streetlight with feet (I just love describing things in this game). For fun you could try pressing the wake up button while you’re a streetlight (don’t worry, it doesn’t wake you up).

Press the Y button on the classic controller to switch the light to red. Okay, now follow the road back to the right a bit. You’ll see a way you can go up and there’s some red thing sticking out of a hole. You guessed it. That leads to the next area.

Now you’re in a small room with a white floor and another red thing that takes you to the next room. Go up the red thing to the right to get there.

Now you’re in a room that’s mostly white. Just walk into the entrance to the right.

Yet another white room, where you’re maybe walking on clouds. Go all the way to the right again.

Now you should finally be in the room where the 0 fps happens. Turn the streetlight green to see what I mean.

I hope I described that well enough. I’m pretty sure I didn’t forget anything at least.

You can wake up now! For the first time ever I could save that I had found an item on Wii!

This really is great. Whoever decided to put that in, thank you :slight_smile:


#29

Thanks for this extensive report.

Yeah, we fixed that issue a while ago. Made a gigantic difference.

These are the footstep sounds. Because they are detected everytime you walk and the Wii is quite slow this results in lots of lag.

Nope, that post was outdated. WAV works now perfectly.
But sound effects don’t use our new audio code yet, which means they play incorrect (usually too slow or too fast)

That’s because the Wii only has one CPU core. When the game needs lots of processing time the music has not time to decode :frowning:

The old music is with high probability wrong (plays too fast or too slow) but verifying this would be important for us.

We reduced the screen size because many televisions had overscan issues, your TV is an exception I guess.

This happens on looping maps when you cross a map boundary, is a bug in our code. Is especially noticable in Yume Nikki because it uses tons of Parallax maps.

The Wii is too slow for full speed when more stuff is rendered but it should still be playable because we frameskip. (as long as you are above 30 FPS it will run quite smooth)

Thanks for these extensive description, we would be happy to always get such detailed bug reports.

I thought this makes most sense because that game is so popular and I don’t know of any other famous games that need anything else besides SHIFT.

You can find a 3dsx in the 3ds-audio-test I linked (that contains the test games).


#33

In the last tests I made, easyrpg player had framerate problems with pictures moving without waits
Maybe the parallel process call the picture once and once again without any time wait when the event finish and restart-
I wanna say that the process repeat faster in player, so it cause redundancy and fps down


#34

Wii build confirmed working by @carstene1ns thx!

The 3DS build is confirmed totally broken, also by somebody else :frowning:


#35

Yup, Wii build works. Ib title screen music also plays normally. However, I tried other midi music tracks and they don’t slow down or speed up respectively


#36

Yeah that depends on which MIDI processor is used. When it uses the audio provided by SDL (a library we use) it will not work. To get our builtin midi (which sounds different) and supports speed changes you have to delete or rename your timidity folder.


#37

Got a chance to use the original pc version for a while so I could compare the music in some areas. I’m happy to report music on the Wii test version sounds accurate :slight_smile:

Any chance there could be an option to toggle whether you need the screen size reduced for people who didn’t have an overscan issue?

(I’m still talking about Yume Nikki btw, haven’t tried anything else)
Specifically because you mentioned smoothness, I’m trying to determine if the frameskip might be making motion look more fluid on emulated Wii (which I’m guessing you guys are using) than on an actual Wii.

Not trying to complain, but it’s very common to see jerkiness when moving while there’s music (the player character will move a step, pause a short moment, move again, pause a short moment…). That starts at around 48-52 fps and is especially noticeable on ramps or stairways.

Would video help? I might be able to capture Wii footage directly by hooking up a dvd recorder and then ripping that to pc. But would be a significant amount of hassle so I’d have to know how useful that would be.

A little more info. That thing in the photo is called http://yumenikki.wikia.com/wiki/The_Thing_with_the_Quivering_Jaw
And it must be the quivering jaw itself which causes the drop to 0 fps, because the stoplight on red turns off the jaw quivering and removes the fps drop.

Minor visual bug:
(this is pretty well hidden in the game but I don’t know how to do spoiler tag here)
This is what UFOs should look like:

This is what UFOs look like on Wii (I haven’t test what they look like on pc EasyRPG):

Seems to be a simple transparency issue. Interestingly, those black boxes don’t show up while the UFOs move into position, only when they reach their final position (which has a different animation).

And don’t mind the colors being off in my picture. That’s just due to the camera settings I was using.

Okay, now how to get there. First of all, you’re gonna need a save game with some items already found:

Fall asleep. Enter the dream bed in the house. If you don’t get teleported to a staircase, wake up and try again. Each time you go to sleep there’s a 1 in 5 chance that the dream bed in the house will teleport you, so it might take a few tries.

When you get teleported to the staircase, go down (to the left). This room also shows the walking jerkiness I was talking about particularly well btw.

Keep going left. You’ll reach a dead end where there’s a fire. Use the umbrella item to make it rain. You can choose the umbrella item again to turn the rain off if you want. Now go left into the next room.

There’s something dangerous looking in this room but it can’t hurt you (other than accidentally blocking your way. Just attack it with the knife if it does that). There’s some obstacles in the room to go around. Go all the way left, then up, then right to reach the exit on the top right of the room.

Now you’re in a white area. Through several rooms, go right until you can’t go right any longer. There’s a bed in this rightmost room, which doesn’t look too obviously like a bed.

Go to sleep in that bed. If the screen only dims partially, get out of the bed then get back in again (do not wake up!). Every time you get in the bed there’s a 1 in 16 chance that the room will dim completely to black. Once that happens and a new sound starts playing, get out of the bed for the final time.

Now, you need the go all the way left as far as you can through several rooms. There’s a stairway to take out of the left most room.

Now you’re on the planet. Just keep going left through several rooms until you can’t go left any farther. You’ll be next to a little hole with smoke or steam coming out.

Choose the cat item and keep pressing Y to meow. You’ll occasionally have a UFO show up when you do that.

If you want to see something else while you’re there, use the midget item and enter the hole.


#39

Came across one more Yume Nikki visual bug.

There’s a maze that’s supposed to flash static which looks like this:

Instead that room just stays black without ever flashing static.

How to get there:
After falling asleep, in the room with all the doors go through the door which looks like this

Then use this map to get to the center of the room (the dark thing surrounded by red stuff).
http://vignette1.wikia.nocookie.net/yumenikki/images/c/c6/Shield_folk_World.png/revision/latest?cb=20110802003043

At that dark thing go under it and press up to get to the static maze.

Should I be posting these Yume Nikki specific things in a different thread? I’ve been posting them here because I’m using the test version linked earlier in the thread.


#40

Currently not, but we plan to eventually make some option menu for Wii specifics, that will allow you to change such settings and save them.

We already have this bug on our list. ^^’

Thanks, we will look into that.

I think it would be cool to have some thread about game specific issues, yeah.
The Player behaves (with some exceptions) on all platforms identically, so it is also easier for you to use it on PC IMO.
btw. I think your explanations are really great and i was able to follow the instructions to find the right places.
However, on the PC version you can pass the --test-play command line flag and be able to save anytime with F11 key, which would make this also easier for us, because we have save games near the issues. :wink:

You can also enable Testplay mode on Wii by adding

<arguments>
  <arg>--test-play</arg>
</arguments>

to your meta.xml in the <app> namespace, however, this needs a keyboard attached to press the key (and was never tested to begin with).


#41

[quote=“gravity, post:39, topic:197, full:true”]
Came across one more Yume Nikki visual bug.

There’s a maze that’s supposed to flash static which looks like this:

Instead that room just stays black without ever flashing static.[/quote]
The framerate drops in the maps where that happens if I’m not wrong…

I’ll give it a try next time…


#42

It sounds like you guys aren’t aware of this, so I’ll report that the Wii player does not respond to keyboard input.

I just double checked and F11 doesn’t do anything on Wii with that entered into meta.xml. Nor does any keyboard button make any normal game actions happen.[quote=“carstene1ns, post:40, topic:197”]
However, on the PC version you can pass the --test-play command line flag and be able to save anytime with F11 key, which would make this also easier for us, because we have save games near the issues. :wink:
[/quote]
Wow! That sure makes things a lot simpler.

I’ve found three Wii-only Yume Nikki freezes and I was dreading trying to describe how to get to those. They’re in some of the most complicated to get to places in the whole game.

Two of them block the only way to get an item, thus preventing the game from being completed on Wii.

Here’s saves right before each of the freezes (save slots 3 to 5):

I saved on pc but double checked and the freezes do still happen on Wii when loading these saves.

On Wii going to the next room results in a freeze where the music continues playing, but nothing you press does anything. The only way to get out of it is to hold down the power button on the Wii until it shuts off.

In slot 3 just move to the left.

In slots 4 and 5 just go to the right. These are also the freezes that prevent getting two items.

BTW I used a speed glitch to get to these locations (it’s a known Yume Nikki glitch, not a problem with the Easy RPG player). I forgot to turn it off before making the saves but it doesn’t affect game behavior in any way except for increasing your speed, and the game freezes on Wii at these points whether or not the speed glitch is active.

If you want to turn off the speed glitch anyway, just go to the menu and use an item. That sets your speed to normal.

And with that all said I’m happy to say that I have now gotten all the items in the game on Wii except for the two that are blocked by those freezes, seen very many of the special events in the game, and explored probably almost every area in the game except for where the Wii freezes are. I’d say there’s a very good chance that all or almost all bugs in the game have now been found, especially anything game-breaking.

On another note I’m kind of tempted to try playing some Yume Nikki inspired fan games soon. Is there a list anywhere of game that are known to be pretty compatible with Easy RPG? Or do most games work pretty well at this point? I think I’ve heard .flow specifically has major problems, for example.


#43

Hm, we probably disabled the keyboard input for Wii because we thought nobody will ever need it :wink:

Thanks. The Wii probably runs out of memory on the map. We will investigate.

Thanks for this complex testing. We are not getting many reports of completable games in Player :slight_smile:

We have a compat list but it is almost empty because nobody gives us feedback: https://wiki.easyrpg.org/user/player/compat
We have a bug report function in the Android version that gives us an overview about issues, thats how we become aware of most.

Which fan games do you plan to play?
ゆめ2っき (Yume 2kki) seems to have some issues but we are not sure if they are fixed in the meanwhile

That’s actually a problem in the game, we detect the engine (2000 or 2003) by extracting that information out of the database and .flow has a 2003 database but ships with a 2000 RPG_RT.exe. This results in the ingame-menu being completely empty.
You can overwrite the engine over the command line to fix this (better create a new folder so it only applies to .flow):

<arguments>
  <arg>--engine</arg>
  <arg>rpg2k</arg>
</arguments>

#44

Lol, that’s actually kind of funny someone would do that considering buttons can’t be configured on Wii. Literally over a year ago I was going to play through Yume Nikki on Wii, but once I realized there was no button to wake up (which means no way to save, because you have to wake up after finding an item in order to save), no way to configure buttons, and that even plugging in a keyboard and pressing the key to wake up doesn’t work… well, I gave up until Yume Nikki specific buttons were just recently added to the Wii test version.

Besides that, I also just found a 0 fps room during the first night of Fleshchild on Wii. I would have saved there and sent that in if Wii allowed you use F11 (I figure I might as well always play with --test-play considering my knack for finding bugs).

I pretty much do all my Easy RPG playing on Wii though because games look so great on a crt tv, and it’s also much bigger than my pc screen. So it really would help me post saves right where a bug is if you guys could get keyboard working on Wii :wink:

Actually, I play with the classic controller, so what I’d really like to be able to do is assign F11 to a Wiimote button, cause I’m never pressing anything on the Wiimote itself anyway.

Oh! There’s an idea. Maybe setting --test-play on Wii could automatically assign a specific button to F11 on the Wiimote. It wouldn’t affect anyone not using --test-play, nor interfere with playing with the classic controller. But it would allow F11 saves on Wii without a keyboard. To be honest I do like that idea better than having to plug in a keyboard to do F11 saves.

That’s too bad. I guess it is always hard to get people to contribute unless there’s a much larger community than there is here.

I’m glad to help. I’ll admit it does get annoying having to go to pc and retrace my steps because Wii can’t press F11 to do save-anywhere right now, so hopefully that can get added soon :stuck_out_tongue:

Oh that’s where it is. I tried to find if there was a compatibility list before asking that and couldn’t find it or even a link to it on the forum. Nor did I see a link to it on the Easy RPG home page. I didn’t think to check for it on the wiki. I kind of think a lot of people wouldn’t either.

I’d strongly suggest putting a link to the list on the homepage, as well as an easily visible link on the forum. And also mentioning that you’re specifically in need of this kind of information.

I guess it is kind of obvious that kind of info would be needed, but if you say it directly in easily visible places you might get lucky and have more people giving information like that. :slight_smile:

I also have to confess that the list is a bit underwhelming. But I’m not talking about the amount of games listed.

There’s several reasons I’m saying that. For example, there’s things like “.flow Playable, needs to specify game engine manually” but the compatibility page doesn’t tell you how to do that. Or for another example there’s “Calm Falls Completable, needs to rename mp3 files” but there’s no description of what to name them to or any link to instructions. That kind of information would be really valuable to have right there or at least linked to from the compatibility page.

Or kind of the opposite problem, “Yume Nikki Playable, graphical glitches”. While there are still two specific spots where there’s a graphic glitch (one of them being very minor), that disclaimer is very misleading because it makes the problem sound like a hugely bigger issue than it really is. So I suggest having some kind of color-coded system for the compatibility rating, like for example this page for Wiisx has (scroll down a little to see it). That would give a bit more context to the descriptions make the severity of problems more obvious.

To be honest having stuff separated into fields like on that page would be much nicer too. Things like compatibility rating, problems/instructions, game version tested (for unfinished games like Yume 2kki), maybe system-specific compatibility problems (for example the Yume Nikki Wii exclusive freezes). Or (considering rpgmaker games are scattered all over the internet) maybe even a “links” field where people could put in a game info and/or download link if they want.

I’m not suggesting that you guys go and look up that information yourselves. But having a field there where people could enter that stuff could maybe someday lead to a compact and convenient way to see what games are compatible, and links to find out more about them and where to get them, all in one spot. That would really be awesome.

I’ve added information to things like the Wiisx compatibility page before so at the least I’d most likely be willing to enter that kind of info for games I end up playing :stuck_out_tongue:

Hmm. I just thought of something else. Maybe there could be a field for known issues pages like this one for Yume Nikki, so people can easily see more in depth information if they want to.

I hope I didn’t get carried away with that idea…

Well the only other suggestion I have would be to have the information on how to do the F11 saving stickied on the forum where people would report bugs. If I’d known about that sooner it definitely would have saved a lot of time and right now it’s very unlikely for someone to find that out without specifically being told.

I was leaning more towards games that probably won’t be updated anymore or for a long while, so Yume 2kki (which I think updates kind of often if I’ve heard right) is something I probably wasn’t going to play soon. But if there’s stuff you aren’t sure is fixed I might put a higher priority on it.

Hmm. I noticed that some things on the command line page like for example “encoding” can be used in the RTP_RT.ini. But Engine=rpg2k does not seem to work there. Can meta.xml be used in each game folder like RTP_RT.ini can, or would .flow actually need a completely separate Easy RPG Wii installation to use the --engine command?

I was testing this on pc and the only way I could get .flow to show anything but Quit on the menu was to run Easy RPG through a shortcut with --engine rpg2k. Which would affect all games of course, even though flow is in it’s own folder. Because of that I don’t see a way .flow could be used on Wii without having a separate Easy RPG installation just for that game, because the only way to use that command is to affect all games. Am I missing something?

I’m sure this is the wrong place to ask, but one final question. Is there an already installed 2000 RTP available for download anywhere? I already have 2003 RTP from Steam (which I could upload if you want) but I don’t have 2000 there. I’m on Windows 10 and it would be much simpler to put an already installed 2000 RTP into /data/rtp/2000 than it would be to figure out how to install it by using something called applocale which is apparently outdated and needs to use a special command line and other stuff.

I’m sure other people would appreciate being able to just extract and use pre-installed RTPs too. :slight_smile:


#45

Technically this is an oversight because we use a different input-mapping sourcefile (not the default one from desktop) and this one only provides button mapping for Wiimote.

The newest version (continious build) provides a way to enter the Debug menu

Enable TestPlay mode from command line (as you already do) and in the ingame menu you see a new option “Debug”.
When the menu is disabled (Ib e.g.) you can force call it with “Hold SHIFT and while holding press B 5 times”. SHIFT = Wiimote A, B = Wiimote 2

Yeah I agree on your points. How we do it is not the best way and could be placed in a more prominent location.
Have to check if dokuwiki allows such table coloring, not sure. But such a fancy table as on that linked page is not possible.

Only Encoding works there because that option was added years ago. The command line is a newer thing. But supporting this stuff through INI is planned for the 0.5 release which comes in a few weeks.

We can’t provide a nice zip download for this due to license issues.
I recommend you to use the RTP from Don Miguel for 2000 and RPG Advocat for 2003 if you usually play European games only.

Most published games actually use the pirated version (illegal translation), so you will have more success with the inofficial RTP translations then with the legal ones :frowning:

@Mr.Faq2014
The 3DS build got fixed and works with WAV, OGG and MP3 again.


Player 3DS Port